automatictester

my thoughts on test automation

Selenium Java bindings 2.44.0, DesiredCapabilities, Platform and Sauce Labs

Those who use Selenium + Java + Sauce Labs combo can run into troubles when upgrading Java bindings from 2.43.1 to 2.44.0. This works fine before the upgrade:

capabilities.setCapability("platform", "Windows 7");

But throws an exception after upgrade:

Exception in thread "main" java.lang.IllegalArgumentException:
   No enum constant org.openqa.selenium.Platform.Windows 7

This is due to implemented matching platform with enum. There is an already fixed Selenium defect for that, but new version of language bindings has not been released yet. Those of you who are affected should revert back from 2.44.0 and wait for subsequent release.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: